Solving TCP port problems with XAMPP and Skype

Recently I tried to run a portable version of XAMPP for a local testing environment in combination with Adobe Dreamweaver and wordpress. Unfortunately I could not start the Apache server from the XAMPP control panel. The little green “running” sign appeared for about two seconds and then disappeared again. Also the XAMPP start page did not work. When I tried to use the start script, the prompt told me:

make_sock: could not bind to address 0.0.0.0:443 no listening sockets available, shutting down

meaning, that the TCP port 443 was allready in use by another aplication. But since I did not install any other server software, I was confused which program would dare to occupy the standard https port… A quick google search helped me to figure out some “command prompt magic” to find the delinquent. The command

netstat -ano | findstr :443

returned

TCP 0.0.0.0:443 0.0.0.0:0 LISTEN 5104

which helped me to find the process ID of the program using port 443, in this case 5104. But since this PID number did not show up in the windows task manager (which scared me a little bit), I again did some googling and found the tasklist command:

tasklist | findstr 5104

revealed that Skype.exe was responsible for the “port occupation”. So I opened up Skype and started looking for reasons. Under “Tools > Options > Advanced > Connection” I found a checkbox labled “Use port 80 and 443 as alternatives for incoming connections”… I unchecked it, restarted skype, et voilà: XAMPP worked like a charm!

Skype setting to use TCP ports 80 and 443

Skype setting to use TCP ports 80 and 443

Hope this helps you (and me again) sometimes… Cheers, Tobi

Posted under Notes to myself, Technik, Wordpress || This post was written by Tobias Kern on February 24, 2012 || Tags: , ,

Trackback URL of this Post: http://www.tobikern.de/2012-02-24/solving-tcp-port-problems-with-xampp-and-skype/trackback

Problems with WP-Super-Cache after updating to WP 3.0.1 – Only a blank page

Well there are no nice pictures in this post, and I admit it is a little bit geeky, but I thought it might help some of the people who ran into the same problems I did, after  upgrading to the latest WP version (3.0.1)

Suddenly my website stopped working at all. I got just a blank white page, with no code whatsoever in it. Even the administrative backend stopped working.

After a long time tinkering around with WP source files and after reestoring the database and the WP- configuration for about 100 times (OK, it was two times, but it felt like 100 times 😉 I figured out that it had something to do with the WP-Supercache-Plugin. after I deleted the line “define(‘WP_CACHE’, true); //Added by WP-Cache Manager” in the wp-config.php I finally could log into my admin backend again.

Unfortunately, whenever I opened the plugin configuratio page it automatically added this line to the config file, rendering my blog useless again.

So, now knowing what was wrong, I did some research. Reading the official installation manual (which quite changed since I installed the plugin a lon time ago) I found out, that there ought to be a second .htaccess-file in the folder “/wp-content/cache/” containing the following:


# BEGIN supercache
<IfModule mod_mime.c>
<FilesMatch "\.html\.gz$">
ForceType text/html
FileETag None
</FilesMatch>
AddEncoding gzip .gz
AddType text/html .gz
</IfModule>
<IfModule mod_deflate.c>
SetEnvIfNoCase Request_URI \.gz$ no-gzip
</IfModule>
<IfModule mod_headers.c>
Header set Cache-Control 'max-age=300, must-revalidate'
</IfModule>
<IfModule mod_expires.c>
ExpiresActive On
ExpiresByType text/html A300
</IfModule>
# END supercache

I also figured out, that my WP-folder did not contain a “wp-cache-config.php” file. After copying the example file from the plugin folder (wp-content/plugins/wp-super-cache/wp-cache-config-example.php) and renaming it to “wp-cache-config.php” my blog started working again. Yipee!

I don’t know if I messed things up during the update-process, or if something else went wrong, but now my blog is working again, and I still can use wp-super-cache, which is a great plugin by the way!

As mentioned above, the official WP Super Cache installation instruction helped me a great deal to figure out my problem. You can find it here http://wordpress.org/extend/plugins/wp-super-cache/installation/

I hope this helps. If you have any suggestions please leave a comment!

Posted under Technik, Wordpress || This post was written by Tobias Kern on November 4, 2010 || Tags:

Trackback URL of this Post: http://www.tobikern.de/2010-11-04/wp-super-cache-probleme-nach-update-auf-wp-3-0-1-nur-noch-weise-seite/trackback

New Theme, new luck…

As you can crearly see, the look of my site has changed! That’s because at the moment I’m tinkering on a new look for my site! So if something goes “boing” while you’re here, please forgive me 🙂 or even better leave me a comment with the stuff that doesn’t work! Thanks!

Posted under Gedanken eines wirren Geistes || This post was written by Tobias Kern on August 28, 2008 || Tags: ,

Trackback URL of this Post: http://www.tobikern.de/2008-08-28/neues-theme-neues-gluck/trackback